web-dev-qa-db-fr.com

WAMP ne deviendra pas vert. Et l'erreur VCRUNTIME140.dll

WAMP ne deviendra pas vert. Cela fonctionnait bien il y a quelques semaines. Lorsqu’on a cherché d’autres réponses à ce sujet, beaucoup ont dit d’installer des services dans Apache.

Lorsque je le fais, je reçois un code d'erreur indiquant:

"Le programme ne peut pas démarrer, car VCRUNTIME140.dll est absent de votre ordinateur. Essayez de le réinstaller pour résoudre le problème."

86
Dylan Caudill

Comme l'a dit Oriol, vous avez besoin des redistribuables suivants avant d'installer WAMP.

À partir du fichier readme.txt

AVANT de procéder à l'installation de Wampserver, vous devez vous assurer que que certains éléments sont installés sur votre système, sinon Wampserver ne fonctionnera absolument pas, et en plus, l'installation sera défectueux et vous devrez désinstaller Wampserver AVANT d’installer le éléments qui manquaient.

Assurez-vous d'être "à jour" dans les packages redistribuables VC9, VC10, VC11, VC13 et VC14 Même si vous pensez être à jour, Installez chaque paquet en tant qu'administrateur et si le message "Déjà installé", validez la réparation. 

Les paquetages suivants (VC9, VC10, VC11) sont impérativement requis pour Wampserver 2.4, 2.5 et 3.0, même si vous utilisez uniquement les versions Apache et PHP VC11 et VC14 est requis pour PHP 7 et Apache 2.4. 17 

https://support.Microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

144
sotoz

Tout simplement:

  1. Désinstaller wampserver
  2. Installer Redistribuable Visual C++ pour Visual Studio 2015
  3. Installer wampserver
40
abdesselam

Erreur VCRUNTIME140.dll

Cette erreur signifie que vous n'avez pas installé les packages Visual C++ requis sur votre ordinateur . Si vous avez installé wampserver, commencez par désinstaller wampserver.

Télécharger les VC packages

Téléchargez tous ces packages VC et installez-les tous. Vous devez installer les versions 64 bits et 32 ​​bits. 

- Packages VC9 (Visual C++ 2008 SP1) --
http://www.Microsoft.com/en-us/download/details.aspx?id=5582
http://www.Microsoft.com/en-us/download/details.aspx?id=2092

-- Packages VC10 (Visual C++ 2010 SP1) --
http://www.Microsoft.com/en-us/download/details.aspx?id=8328
http://www.Microsoft.com/en-us/download/details.aspx?id=13523

-- Packages VC11 (Visual C++ 2012 Update 4) -
Les deux fichiers à télécharger VSU4\vcredist_x86.exe et VSU4\vcredist_x64.exe se trouvent sur la même page 
http://www.Microsoft.com/en-us/download/details.aspx?id=30679

-- VC13 Packages] (Visual C++ 2013) -
Les deux fichiers à télécharger VSU4\vcredist_x86.exe et VSU4\vcredist_x64.exe se trouvent sur la même page
https://www.Microsoft.com/en-us/download/details.aspx?id=40784

- Packages VC14 (Visual C++ 2015) -
Les deux fichiers vcredist_x86.exe et vcredist_x64.exe à télécharger se trouvent sur la même page
http://www.Microsoft.com/en-us/download/details.aspx?id=48145

install paquets avec privilèges admin
Clic droit-> Exécuter en tant qu’administrateur

installe à nouveau wampserver
Après avoir installé la version 64 bits et 32 ​​bits des packages VC, installez à nouveau wampserver.

9
Harun ERGUL

Vous devez installer certains packages Visual C++ AVANT d’installer WAMP (si vous avez déjà installé, vous devez désinstaller et réinstaller).

Vous avez besoin de: VC9, VC10, VC11, VC13 et VC14

Dans readme.txt de wampserver 3 (sur SourceForge), vous pouvez trouver les liens.

Faites attention! Si vous utilisez un système d'exploitation 64 bits, vous devez installer les deux versions de chaque package.

9
Oriol Tauleria

J'ai eu le même problème et je l'ai résolu en installant:

NB: L'installation en 64 bits était suffisante, je devais désinstaller/réinstaller Wamp après cela

3
ccarrez

Comme vous disposiez déjà d’une version en cours d’exécution de WAMP et que celle-ci ne fonctionnait plus, VCRUNTIME140.dll était probablement déjà installé. Dans ce cas:

  1. Programmes ouverts et fonctionnalités
  2. Cliquez avec le bouton droit de la souris sur les programmes d'installation redistribuables Microsoft Visual C++ 20xx respectifs et choisissez "Modifier".
  3. Choisissez "Réparer". Faites ceci pour x86 et x64

Cela a fait le tour pour moi.

2
David Niki

Après avoir beaucoup installé et désinstallé pendant une journée entière et essayé chaque paquet pour chaque réponse, la seule chose qui a fonctionné pour moi a été:

  1. Désinstallez Wamp et redémarrez
  2. installez Visual Studio 2017 Community Edition et choisissez "Développement Web", puis cochez toutes les options du bon site. Voici une capture d'écran:  enter image description here

En quelque sorte, installez quelque chose qui est également nécessaire pour Wamp.

  1. installez Wamp, et vous devriez être tout bon.

Lien vers visual studio 2017 Community Edition

0
Rami Nour

WAMP ne devient pas VERT? Ne paniquez pas

Tout d'abord, vérifiez votre mise à jour Windows en cherchant "Windows Update"

ou

Téléchargez les mises à jour à partir du site Windows de Windows (Windows 7 x 64 a été mis à jour vers le Service Pack 1 complet) téléchargement du Service Pack 1 pour Windows 7

Maintenant, il y a quelques téléchargements supplémentaires qui supportent WAMP pour l'installation

À partir du fichier readme.txt

AVANT de procéder à l'installation de Wampserver, vous devez vous assurer que que certains éléments sont installés sur votre système, sinon Wampserver ne fonctionnera absolument pas, et en plus, l'installation sera défectueux et vous devrez désinstaller Wampserver AVANT d’installer le éléments qui manquaient.

Assurez-vous d'être "à jour" dans les packages redistribuables VC9, VC10, VC11, VC13 et VC14 Même si vous pensez être à jour, Installez chaque paquet en tant qu'administrateur et si le message "Déjà installé", validez la réparation.

Les paquetages suivants (VC9, VC10, VC11) sont impérativement requis pour Wampserver 2.4, 2.5 et 3.0, même si vous utilisez uniquement Apache et PHP les versions VC11 et VC14 sont requises pour PHP 7 et Apache 2.4.17

Packages VC9 (Visual C++ 2008 SP1) _ { https://www.Microsoft.com/en-us/download/details.aspx?id=5582 } _ _ { https://www.Microsoft.com/en-us/download/details.aspx?id=2092 } _

Packages VC10 (Visual C++ 2010 SP1) _ { https://www.Microsoft.com/en-us/download/details.aspx?id=8328 _ { https://www.Microsoft.com/en-us/download/details.aspx?id=13523 } _

Packages VC11 (Visual C++ 2012 Update 4) Les deux fichiers Les fichiers VSU4\vcredist_x86.exe et VSU4\vcredist_x64.exe à télécharger sont activés la même page: _ { http://www.Microsoft.com/en-us/download/details.aspx?id=30679 } _

Packages VC13 [/ b] (Visual C++ 2013) Les deux fichiers VSU4\vcredist_x86.exe et VSU4\vcredist_x64.exe

Packages VC14 (Visual C++ 2015) Les deux fichiers vcredist_x86.exe et vcredist_x64.exe à télécharger se trouvent sur la même page: (https://www.Microsoft.com/en-us/download/details.aspx?id=52685 } _

Packages VC x64 (Visual C++ 2017)

https://support.Microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

0
Bhavsar1311